Настройка OpenVPN на Mikrotik в tunnel mode

Конфигурация сервера:

создаем пустой бридж или указываем существующий:

/interface bridge
add name=ovpn-bridge

создаем ip-пул для выдачи клиентам:

/ip pool
add name=ovpn-pool ranges=172.16.50.2-172.16.50.20

настраиваем профайл для клиентов:

/ppp profile
add bridge=ovpn-bridge local-address=172.16.50.1 name=ovpn-prof remote-address=ovpn-pool

добавляем связку логин-пароль:
/ppp secret
add name=admin password=pass profile=ovpn-br-prof service=ovpn

настраиваем сам сервер:

/interface ovpn-server server
set certificate=server.crt_0 cipher=blowfish128,aes128,aes192,aes256 default-profile=ovpn-prof enabled=yes \
keepalive-timeout=disabled mode=ethernet port=443 require-client-certificate=yes

добавляем исключение в firewall:

/ip firewall filter
add action=accept chain=input dst-address=195.171.128.2 dst-port=443 protocol=tcp

Конфигурация клиента:
/interface ovpn-client
add add-default-route=yes certificate=pi.crt_0 cipher=aes256 connect-to=195.171.128.2 mac-address=02:CF:0A:DD:7D:E6 mode=ethernet name=test-client password=\
pass port=443 user=admin

nnk